Início » Meu-Android » Como tornar qualquer App compatível com qualquer versão do Android

Como tornar qualquer App compatível com qualquer versão do Android

A fragmentação do Android têm sido alvo de diversas críticas ao redor do mundo. Por um lado, smartphones seriam uma realidade mais presente em países mais pobres e mercados emergentes, onde não se pode comprar um top de linha. Por outro, essa mesma gama de aparelhos baratos são, na maioria das vezes, abandonados ainda no lançamento, alguns sem receber nem sequer uma atualização de sistema.

Essa escassez de atualizações pode interferir na usabilidade do aparelho, tornando uma pequena parcela das aplicações incompatíveis para determinada versão do Android, como foi o caso de Pokémon Go, dando aquela clássica mensagem de erro: “houve um erro com a análise do pacote”.

Ads code goes here

Essa mensagem significa que seu sistema não conseguiu fazer uma leitura do aplicativo em questão, que muitas vezes pode indicar uma incompatibilidade. No tutorial abaixo, iremos ajudar a burlar essa limitação e instalar aplicações e jogos não suportados pela sua versão do sistema.

  1. Baixe a aplicação “Apk Editor” aqui, ele é gratuito na Google Play.
  2. Ao abrir o Apk Editor, você verá a tela abaixo. Selecione a primeira opção e navegue até a pasta onde está o arquivo .APK que você deseja modificar.
  3. Assim que selecionado o arquivo, escolha a opção  “Edição Comum”.
  4. Após selecionar, você irá se deparar com a tela abaixo. Nela é possível observar os dizeres “Minimum SDK Version”. Abaixo dela há uma caixa de texto com um número, que pode variar de APP para APP.
  5. Substitua o número em questão pelo equivalente à sua versão do Android. Caso não saiba o seu, realize uma pesquisa rápida na web.
  6. Depois de ter modificado o número, escolha a opção salvar e espere alguns instantes enquanto o Apk Editor carrega seu arquivo. Em seguida, quando terminar o carregamento, você poderá instalar seu aplicativo normalmente, sem nenhum tipo de erro.

Segue abaixo a lista de todos os níveis de API (SDK

Vale a pena lembrar que não é recomendado fazer isso em aplicações que alterem as configurações do sistema, como é o caso de Emoji Switcher, pois o software pode ter sido determinado para uma versão posterior do Android. Este artigo serve tanto para aplicativos quanto para jogos, como é o caso de Pokemon Go, Mario Run e Minecraft PE.

Sobre Rafael Paluzzi

Apaixonado por tecnologia, games e pelo mundo geek. Gosto muito de me manter informado sobre tudo que acontece no mundo mobile e acredito fielmente em Deus.
%d blogueiros gostam disto: